Backup WebCell Data to Your Computer

Top  Previous  Next

The standard home automation web pages store all the information you enter about your home automation system in a file on the memory card in the WebCell. As with all of your data, it is good idea to backup this file from time to time. This file is backed up by copying it to the WebCell project on your computer.

 

There are two ways to backup WebCell data:

Setting up synchronization. We recommend this method for users who do not need to simulate the WebCell.

Manual file copy. This approach may be necessary for developers.

Setting Up Synchronization

From the Tools menu, select the Options... command. Select the Project Sync tab at the top of the dialog box. In the Data Folder section, check the boxes for Allow sync and Bidirectional. Click the OK button to save these settings.

 

These steps will set up two-way synchronization of files based on date/time stamp. If the data files on the WebCell are the newest, they will be copied to your computer. Conversely, if the data files on your computer are newer, they will be copied to the WebCell. This works fine for backing up the WebCell data as long as you don't use the simulation feature, which could cause your computer's data to be more recent than the WebCell data.

 

With these settings in place, you can backup the data by simply performing a synchronization between your computer and the WebCell.

 

Synchronizing the WebCell

To back up WebCell data, go to the Tools menu and select the Sync Once command. Alternatively, click the synchronize button Sync on the toolbar.

 

Note that synchronization will also update the web pages on the WebCell if the project web pages have been updated.

Manual Data Backup

From the View menu, select the Cell Files... command. This will open a view of files in the WebCell project on both your computer and on the WebCell. The view is similar to Windows Explorer, with the folder tree in the left pane and files in the selected folder in the right pane.

 

To backup WebCell data to your computer, follow these steps:

1.In the left pane, expand the root of the folder tree.

2.Right click the folder named data.

3.From the context menu, select the Copy All From Cell command. (Make sure you don't select Copy All To Cell by mistake!)